Your Ad Here

IBM AIX/UNIX system storage administration ksh/perl scripting

Wednesday, March 04, 2009

NIM server setup for dummies

1. Create LV, filesystem /export/nim


mklv -t jfs2 -y nimlv rootvg 3G hdisk1

crfs -v jfs2 -d nimlv -m /export/nim -A yes


mount /export/nim



2. Check whether bootpd and tftpd are running, if not, start them up.


egrep "bootpd|tftpd" /etc/inetd.conf

If the entry is commented out, remove the # sign at the beginning.

lssrc -l -s inetd|grep bootpd
lssrc -s tftpd

If bootpd is not active,

refresh -s inetd

If tftpd is not active,

startsrc -s tftpd


Check the status again.

lssrc -l -s inetd|grep bootpd
bootps /usr/sbin/bootpd bootpd /etc/bootptab active

lssrc -s tftpd
Subsystem Group PID Status
tftpd tcpip 365000 active

3. Set up NIM master

My AIX 5.3 depot is in /depot/AIX3DVD, if you use CD/DVD, change it to /dev/cd0.
-B means Do not make mksysb
-F means Do not make filesysetems

nim_master_setup -a device=/depot/AIX3DVD -BF

############################## NIM master setup ##############################
# #
# During script execution, lpp_source and spot resource creation times #
# may vary. To view the install log at any time during nim_master_setup, #
# run the command: tail -f /var/adm/ras/nim.setup in a separate screen. #
# #
##############################################################################




4. List all NIM objects that have been created by the script above.


lsnim
master machines master
boot resources boot
nim_script resources nim_script
master_net networks ent
master_net_conf resources resolv_conf
5300-04bid_ow resources bosinst_data
530lpp_res resources lpp_source
530spot_res resources spot
basic_res_grp groups res_group


5. Update the latest patches to lpp_res and spot_res.

Again,
-B means Do not make mksysb
-u means Do not update on NIM clients
-d to specify patches location.


/usr/sbin/nim_update_all -l 530lpp_res -s 530spot_res -Bu -d /depot/AIX3patches

6. Detect and remove the duplicated and conflict filesets on lpp resource.

lsnim
master machines master
boot resources boot
nim_script resources nim_script
master_net networks ent
master_net_conf resources resolv_conf
5300-08bid_ow resources bosinst_data
530lpp_res resources lpp_source
530spot_res resources spot
basic_res_grp groups res_group

lsnim -l 530lpp_res
530lpp_res:
class = resources
type = lpp_source
arch = power
Rstate = ready for use
prev_state = verification is being performed
location = /export/nim/lpp_source/530lpp_res
simages = yes
alloc_count = 0
server = master

Detect duplicated
 /usr/lib/instl/lppmgr -d /export/nim/lpp_source/530lpp_res -bu

Actually remove duplicated
 /usr/lib/instl/lppmgr -d /export/nim/lpp_source/530lpp_res -bu -r 

No comments:

Labels

Blog Archive

BlogCatalog