Disabling undesired TCP/IP services in AIX
Abstract
With the increased interest in computing and network security, many AIX users are implementing ssh and ssl, and have interest in turning off several TCP/IP services that are on by default in AIX.
The script that follows is an example of how this was done in one customer implementation. Two comments: 1) a machine that will be a nim server must have bootps and tftpd services ON in /etc/inetd.conf. 2) If using the following script during a nim client install, it should not be used as a post-install script; instead, run it as a first boot script (fb_scripts run after the nim client process completes, and after the client reboots.). Now the script:
#!/bin/ksh
cp /etc/inetd.conf /etc/inetd.conf.original
cat /etc/inetd.conf.original | sed s/^ftp/#ftp/ | sed s/^telnet/#telnet/ \
| sed s/^shell/#shell/ | sed s/^kshell/#kshell/ \
| sed s/^login/#login/ | sed s/^klogin/#klogin/ \
| sed s/^exec/#exec/ | sed s/^bootps/#bootps/ \
| sed s/^ntalk/#ntalk/ | sed s/^tftp/#tftp/ >/etc/inetd.conf
cp /etc/rc.tcpip /etc/rc.tcpip.original
cat /etc/rc.tcpip.original | \
sed s/^qpi=30m/#qpi=30m/ | \
sed s/"^start \/usr\/lib\/sendmail"/"#start \/usr\/lib\/sendmail"/ | \
sed s/"^start \/usr\/sbin\/snmpd"/"#start \/usr\/sbin\/snmpd"/ | \
sed s/"^start \/usr\/sbin\/portmap"/"#start \/usr\/sbin\/portmap"/ | \
sed s/"^start \/usr\/sbin\/dpid2"/"#start \/usr\/sbin\/dpid2"/ >/etc/rc.tcpip
cp /etc/inittab /etc/inittab.original
cat /etc/inittab.original | sed s/^rcnfs/:rcnfs/ | \
sed s/^qdaemon/:qdaemon/ | \
sed s/^writesrv/:writesrv/ > /etc/inittab
/usr/bin/refresh -s inetd
My blog has moved,please visit the new site
IBM AIX/UNIX system storage administration ksh/perl scripting
Wednesday, March 05, 2008
Subscribe to:
Post Comments (Atom)
Labels
- ACL (1)
- admin (2)
- AIX 5.3 (1)
- AIX 6.1 (3)
- Atape (1)
- backup (5)
- backupios (1)
- Best Practices (1)
- bosboot (1)
- cdrom (1)
- cfgmgr (1)
- commands (4)
- compatibility (1)
- console (1)
- device (2)
- dhcp (1)
- disk (1)
- DNS (2)
- Downloads (1)
- dump (1)
- Dynamic (1)
- error (1)
- errpt (1)
- ESS (1)
- etherchannel (1)
- Filesystem (7)
- firmware (2)
- Freeware (1)
- ftp (2)
- getty (1)
- GNU (1)
- HACMP (2)
- HEA (1)
- HMC (2)
- hostname (1)
- I/O (1)
- Installation (2)
- installp (2)
- IP alias (1)
- iptrace (1)
- iso (2)
- IVM.CLI (1)
- jfs (1)
- JFS to JFS2 conversion (1)
- jfs2 (2)
- kdb (1)
- kernel (1)
- LED (2)
- lifecycle (2)
- Live Partition Mobility (1)
- lofiadm (1)
- login (1)
- LPAR (1)
- lppchk (1)
- lsof (1)
- LV (1)
- lvm (3)
- memory (1)
- migration (4)
- mksysb (2)
- mkvdev (1)
- mkvgdata (1)
- mount (1)
- multibos (1)
- ndd (2)
- netstat (1)
- network (7)
- NFS (2)
- NIC (4)
- NIM (2)
- NPIV (1)
- ODM (2)
- openssh (1)
- oslevel (1)
- patching (1)
- Performance (4)
- Perl (2)
- Perl Module (2)
- permission (1)
- port (1)
- Power VM (1)
- Power5 (1)
- Power6 (1)
- printer (1)
- problem (17)
- process (4)
- RAID5 (1)
- Recovery (2)
- respawn (1)
- restore (1)
- routing (4)
- RSC (1)
- runq (1)
- savevg (1)
- scripts (4)
- SEA (1)
- security (5)
- sendmail (1)
- solaris (7)
- SSA (1)
- SSH (2)
- ssh-agent (1)
- storage (3)
- subnet (1)
- Sun Remote System Control (1)
- support (2)
- synchronize (1)
- TCPIP (5)
- telnet (2)
- time zone (1)
- topas (1)
- Total Storage (1)
- trace (2)
- tuning (1)
- uninstall (1)
- update (1)
- update boot (4)
- upgrade (3)
- users (2)
- Veritas Volume Manager (1)
- VG (1)
- VIOS (4)
- VMM (1)
- VxVM (1)
- wtmp (1)
Blog Archive
-
▼
2008
(28)
-
▼
March
(9)
- 0516-070 : LVM system call found an unaccountable ...
- The ps command enhancement (5300-05)
- Firmware upgrade on IBM p-series 9111-520 without HMC
- Tunable IPC/Shared Memory Kernel Parameters in AIX
- Recovery from rm * from the Root (/) Directory in ...
- How to mount ISO image file on AIX.
- Enhanced login privacy for AIX 5L Version 5.2.0 A...
- Why Numbers from "du -s" and "df" DisagreeThis doc...
- Disabling undesired TCP/IP services in AIXAbstract...
-
▼
March
(9)
No comments:
Post a Comment